Amethyst Platform - Website is experiencing increased latecy – Incident details

Website is experiencing increased latecy

Resolved
Operational
Started about 5 years agoLasted about 1 hour

Affected

Website

Operational from 5:49 PM to 6:51 PM

Updates
  • Resolved
    Resolved

    The performance is back to normal.

  • Investigating
    Investigating

    We are currently investigating this incident.

  • Identified
    Identified